ETC2纹理压缩在OpenGL ES 2.0中可用吗?

我有一个ES 2.0的应用程序,并希望使用ETC2纹理压缩,如果它是可用的(即我运行在支持ES 3.0标准的设备上)。 是否有可能在ES 1.1 / 2.0中使用ETC2,如果有的话如何查询设备是否支持? 对于大多数forms的纹理压缩,有一个我可以查询的扩展名,但是ETC2没有扩展名,因为它是内置的。

有一些与ETC2支持相关的GL扩展:

OES_compressed_ETC2_RGB8_texture OES_compressed_ETC2_sRGB8_texture OES_compressed_ETC2_punchthroughA_RGBA8_texture OES_compressed_ETC2_punchthroughA_sRGB8_alpha_texture OES_compressed_ETC2_RGBA8_texture OES_compressed_ETC2_sRGB8_alpha8_texture 

ES3兼容性扩展集合了这些(和其他一些)。 你可以查询这些扩展来检查支持,据推测。